分享
目前身份: 訪客

錯誤的訊息如下:

Your requirements could not be resolved to an installable set of packages.

Problem 1
    - This package requires php ^7.1.3 but your PHP version (7.0.33) does not satisfy that requirement.
  Problem 2
    - Installation request for doctrine/inflector v1.3.0 -> satisfiable by doctrine/inflector[v1.3.0].
    - doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement.
  Problem 3
    - Installation request for laravel/framework v5.8.8 -> satisfiable by laravel/framework[v5.8.8].
    - laravel/framework v5.8.8 requires php ^7.1.3 -> your PHP version (7.0.33) does not satisfy that requirement.
  Problem 4
    - Installation request for nesbot/carbon 2.16.1 -> satisfiable by nesbot/carbon[2.16.1].
    - nesbot/carbon 2.16.1 requires php ^7.1.8 || ^8.0 -> your PHP version (7.0.33) does not satisfy that requirement.
  Problem 5
    - Installation request for symfony/console v4.2.4 -> satisfiable by symfony/console[v4.2.4].
    - symfony/console v4.2.4 requires php ^7.1.3 -> your PHP version (7.0.33) does not satisfy that requirement.

............

這個問題的原因就是因為你的php的版本太舊了,我去查了一下我的版本,是7.0,它要求的是7.3

所以必須要升級成7.3這一步才能過,ok

具體升級php 7.3的方法,請參閱此篇

 

 

 

 

 

 

 

 

2
T.E的Laravel 發表在 留言 (0) 人氣 (99)
Laravel 學習
分享給朋友
網址

想對外分享這則貼文嗎?運用網址更方便呦~

T.E的Laravel

關於
專門記錄學習Laravel的過程與經歷,與突破困難點時的解決方法,和專家的經驗分享、各種知識點,整個學習Laravel的過程,就是自我提昇能力的過程。
貼文分類
最新貼文
誰來我家
  • 08-07  訪客(35.169.107.*)
  • 08-07  訪客(46.229.168.*)
  • 08-07  訪客(66.249.71.*)
  • 08-07  訪客(66.249.71.*)
OnceHit© 2020
載入中...